• 之前是好的 但是我升级了最新的之后好像又不行了 element_by_name @xdf

    >> responseHandler.js:47:14 [master] pid:11720 Send HTTP Respone to Client[2017-
    06-15 22:10:02]: {"sessionId":"f66386bf-1cc7-4122-b6ae-ec937aa478a9","status":0,
    "value":"{\"androidProcess\":\"com.tencent.mm:tools\",\"reuse\":\"3\",\"package\
    ":\"com.tencent.mm\",\"udid\":\"C4Y5T16810004018\",\"autoAcceptAlerts\":\"True\"
    ,\"activity\":\".ui.LauncherUI\",\"platformName\":\"Android\"}"}
    >> responseHandler.js:11:12 [master] pid:11720 Recieve HTTP Request from Client[
    2017-06-15 22:10:07]: method: POST url: /wd/hub/session/f66386bf-1cc7-4122-b6ae-
    ec937aa478a9/element, jsonBody: {"using":"name","value":"微信"}
    >> proxy.js:55:14 [master] pid:11720 Proxy: /wd/hub/session/:sessionId/accept_al
    ert:POST to http://127.0.0.1:9005/wd/hub/session/:sessionId/accept_alert:POST wi
    th body: {}
    >> proxy.js:83:20 [master] pid:11720 Got response with status 200: {"status":0,"
    sessionId":null}
    >> proxy.js:55:14 [master] pid:11720 Proxy: /wd/hub/session/f66386bf-1cc7-4122-b
    6ae-ec937aa478a9/element:POST to http://127.0.0.1:9005/wd/hub/session/:sessionId
    /element:POST with body: {"using":"name","value":"微信"}
    >> proxy.js:83:20 [master] pid:11720 Got response with status 200: {"status":32,
    "value":"Argument was an invalid selector (e.g. XPath/CSS).","sessionId":"f66386
    bf-1cc7-4122-b6ae-ec937aa478a9"}
    >> session.js:107:14 [master] pid:11720 Send HTTP Respone to Client[2017-06-15 2
    2:10:07]: {"status":32,"value":"\"Argument was an invalid selector (e.g. XPath/C
    SS).\"","sessionId":"f66386bf-1cc7-4122-b6ae-ec937aa478a9"}
    >> responseHandler.js:11:12 [master] pid:11720 Recieve HTTP Request from Client[
    2017-06-15 22:10:07]: method: DELETE url: /wd/hub/session/f66386bf-1cc7-4122-b6a
    e-ec937aa478a9, jsonBody: {}
    >> session.js:80:12 [master] pid:11720 Delete session, sessionId: f66386bf-1cc7-
    4122-b6ae-ec937aa478a9
    >> responseHandler.js:47:14 [master] pid:11720 Send HTTP Respone to Client[2017-
    06-15 22:10:07]: {"sessionId":"f66386bf-1cc7-4122-b6ae-ec937aa478a9","status":0}
    
  • IOSDriver 启动时间问题 at 2017年06月07日

    找到解决办法 不用每次都重新build wda吗?

  • 是不是定位定错了?

  • 确认是不是打开下面的路径的.xcodeproj ,然后改development team 重新build successful就可以了
    /usr/local/lib/node_modules/app-inspector/node_modules/xctestwd/XCTestWD/XCTestWD.xcodeproj
    xcode打开的工程路径是不是对的 。
    不要打开/usr/local/lib/node_modules/macaca-ios/node_modules/xctestwd/XCTestWD/XCTestWD.xcodeproj
    xcode更新到最新版

  • 是不是最新版的啊 2.0.1 我 这边刚刚试了下 是好的

  • C:\Users\Summe\AppData\Roaming\npm\node_modules\app-inspector\node_modules\uiautomatorwd\app\build\outputs\apk\app-debug.apk
    这个路径下的apk有没有?
    手机上是不是已经存在这个app?
    如果没有,重新下载macaca驱动,
    将手机上的
    android-unlock
    com.macaca.android.testing.test
    UiAutomator sample
    这三个app卸载掉再试试看

  • 什么意思?

  • 我是每次webview跑完后,就用命令把电脑上的chromedriver的进程给干掉,然后下次在跑脚本进入到webview就不会有问题了。
    可能的原因就是你第二次进入到webview后,原先的chromedriver的进程还在运行导致这次的起不来所致的。

  • 是的 先把原来的wd卸载掉 pip install wd ,再重新安装上,再跑用例就好了。 最新的wd版本是0.1.7

    testdeMac-mini:~ test$ pip install wd
    Collecting wd
    Requirement already satisfied: enum34 in /usr/local/lib/python2.7/site-packages (from wd)
    Requirement already satisfied: retrying in /usr/local/lib/python2.7/site-packages (from wd)
    Requirement already satisfied: requests in /usr/local/lib/python2.7/site-packages (from wd)
    Requirement already satisfied: six>=1.7.0 in /usr/local/lib/python2.7/site-packages (from retrying->wd)
    Installing collected packages: wd
    Successfully installed wd-0.1.7