问答 appium1.6.5,出现的状况 Sdk '10.1.1' was not in list of simctl sdks,请大神们指教

浅浅 · 2017年07月18日 · 最后由 aiyanyuan 回复于 2017年10月27日 · 141 次阅读

appium1.6.5
xcode8.2
Mac 机上真机测试
Mac 机版本 10.12.5
手机版本 10.1.1
出现报错:Sdk '10.1.1' was not in list of simctl sdks

共收到 15 条回复 时间 点赞

之前电脑是不是没有连接过这个版本的真机? 手机连接上电脑, 打开 Xcode, 选择一个项目, 安装一下

你没有这个 sdk

@mamian &Lihuazhang 谢谢!

mark 回复

谢谢

@mamian 大神,有关于上述问题,昨天按你说的方法解决了,今天这样的情况又出现了,按照昨天的方法解决不了了
楼下有没有遇到类似的情况

@GESHUOYAN 你好你这个问题 怎呢 解决的? 我的环境跟你一样, 运行脚本再模拟器上跑就没事,跑真机 就报错,Sdk '10.3.2' was not in list of simctl sdks

@17701331064 你按照 1 楼方法操作一遍试试

能不能加你 qq 咨询一下

@17701331064 你这个问题就是 Xcode 没有配置手机的事情,打开 Xcode,连接真机等待 Xcode 配置完成就 OK

浅浅 #10 · 2017年07月23日 Author

@mads 当然可以了

浅浅 回复

qqqq 多少

浅浅 #12 · 2017年07月24日 Author

@mads 1290688959

浅浅 回复

要验证信息

浅浅 #14 · 2017年07月24日 Author

葛硕颜 你试试,如果不可以我可以加你

我是用 ios 的模拟器跑的,版本是 11.0.1,提示错误
我怕的 appium 是启动了的,求助大佬指教

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册