UiAutomator 想请教一下,python+uiautomator 操作不了 7.0

刘刘刘 · 2017年04月28日 · 最后由 testBlue 回复于 2019年02月13日 · 3195 次阅读

小白请教,python+uiautomator 无法操作 7.0,操作 6.0 正常。查看日志说 write failed epipe.python 报错信息是 ioerror RPC server not started

共收到 8 条回复 时间 点赞

跟 JDK 和 SDK 有关吗?更新到最新不知道有没有用。

Android 7.0 系统不再支持 uiautomator 1.0 了 !

前两天还用着,7.1 的系统,滑动点击可以用,找控件等没用过。

zsg5566 回复

真的假的,有官方说明不

Zhhh 回复

是吗?很纠结,不知道为什么操作不了 7.0 你看下,d.press.home 这些常规操作能用吗。

问题已经解决了,因为 7.0 的手机不会自动安装 app-uiautomator.apk 和 app-uiautomator-test.apk。手动装一下就可以了。

用 2.0 才行 1.0 不支持安卓 7.0

—— 来自 TesterHome 官方 安卓客户端

刘刘刘 回复

请教一下,我已经手动成功安装了这俩个 apk,但是还是无法运行,报错信息是一样,是不是必须要手动再启动下才可以

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册