Macaca Macaca 是否最低支持 ios 到 9.0?

Michael_Wang · February 17, 2017 · Last by Michael_Wang replied at February 18, 2017 · 677 hits

Macaca 最低支持 ios 到9.x 吗?

在官方文档中没有找到相关说明

我自己测试的结果,ios 9系统可以跑起来,ios 8系统跑步起来,不能安装 webdriveragentrunner

从 log 里看,在多次尝试启动 wda server,如果是 iOS 9,会自动进行安装。

Macaca log:

>> xctest-client.js:56:14 [master] pid:1180 project path: /usr/local/lib/node_modules/macaca-ios/node_modules/.1.0.41@webdriveragent/WebDriverAgent/WebDriverAgent.xcodeproj
>> macaca-ios.js:145:10 [master] pid:1180 {
"bundleId": "com.smzdm.client.ios",
"platformVersion": "8.3",
"platformName": "iOS"
}
>> macaca-ios.js:149:12 [master] pid:1180 Trying to start wda server...
BundleId com.apple.test.WebDriverAgentRunner-Runner does not exist.
>> macaca-ios.js:149:12 [master] pid:1180 Trying to start wda server...
BundleId com.apple.test.WebDriverAgentRunner-Runner does not exist.
>> macaca-ios.js:149:12 [master] pid:1180 Trying to start wda server...
BundleId com.apple.test.WebDriverAgentRunner-Runner does not exist.
>> macaca-ios.js:149:12 [master] pid:1180 Trying to start wda server...
BundleId com.apple.test.WebDriverAgentRunner-Runner does not exist.
>> responseHandler.js:54:12 [master] pid:1180 Send Error Respone to Client: Error: 2017-02-17 19:58:08.545 ios-deploy[1920:9043068] [ !! ] [ ERROR ] Could not uninstall package with bundle id com.apple.test.WebDriverAgentRunner-Runner

>> responseHandler.js:60:14 [master] pid:1180 Error: 2017-02-17 19:58:08.545 ios-deploy[1920:9043068] [ !! ] [ ERROR ] Could not uninstall package with bundle id com.apple.test.WebDriverAgentRunner-Runner

at ChildProcess.<anonymous> (/usr/local/lib/node_modules/macaca-ios/node_modules/.0.1.4@ios-device/lib/helper.js:46:17)
at emitTwo (events.js:87:13)
at ChildProcess.emit (events.js:172:7)
at maybeClose (internal/child_process.js:818:16)
at Socket.<anonymous> (internal/child_process.js:319:11)
at emitOne (events.js:77:13)
at Socket.emit (events.js:169:7)
at Pipe._onclose (net.js:469:12)
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
共收到 2 条回复 时间 点赞

wda最低支持9吧,应该可以

#1楼 @Lihuazhang 看到去年 @chenhengjie123 在你的 webdriveragent 介绍贴里提到最低只支持iOS 9.0

需要 Sign In 后方可回复, 如果你还没有账号请点击这里 Sign Up