AppCrawler 新手小白,读了使用手册,并 google,但还是没有解决问题,请各位帮忙看一下,为什么会提示我找不到设备呢?

tester08 · October 25, 2017 · Last by tester08 replied at October 26, 2017 · 1921 hits

环境:appcrawler v2.1.1,appium v1.7.1 xcode 7.3
命令:java -jar appcrawler-2.1.1.jar -a /Users/autohome/Downloads/CarPrice_V_201710240959.ipa —capability platformVersion='9.3.5',bundleId='com.autohome.quote'
现象:无法启动app并运行
log1:appcrawler端
2017-10-25 19:08:48 INFO [AppCrawler$.main.85]
————————
AppCrawler 2.1.1 [霍格沃兹测试学院特别纪念版]
app爬虫, 用于自动遍历测试. 支持Android和iOS, 支持真机和模拟器
帮助文档: http://seveniruby.gitbooks.io/appcrawler
移动测试技术交流: https://testerhome.com
感谢: 晓光 泉龙 杨榕 恒温 mikezhou yaming116 沐木
感谢如下公司提供商业支持: Keep
————————————————

2017-10-25 19:08:48 INFO [AppCrawler$.parseParams.217] Set Platform=iOS
2017-10-25 19:08:48 INFO [AppCrawler$.parseParams.232] app path = /Users/autohome/Downloads/CarPrice_V_201710240959.ipa
2017-10-25 19:08:48 INFO [AppCrawler$.parseParams.243] use default appium address 4723
2017-10-25 19:08:48 INFO [AppCrawler$.parseParams.250] appium address = Some(http://127.0.0.1:4723/wd/hub)
2017-10-25 19:08:48 INFO [AppCrawler$.parseParams.262] result directory = iOS_20171025190848
2017-10-25 19:08:49 INFO [Crawler.loadPlugins.81] dynamic load plugin in /Users/autohome/Downloads/plugins/
2017-10-25 19:08:51 WARN [Runtimes$.loadPlugins.83] no /Users/autohome/Downloads/plugins/ directory, skip
2017-10-25 19:08:51 INFO [Crawler.loadPlugins.83] found dynamic plugins size 0
2017-10-25 19:08:51 INFO [Crawler.$anonfun$loadPlugins$5.85] com.testerhome.appcrawler.plugin.TagLimitPlugin@52f57666
2017-10-25 19:08:51 INFO [Crawler.$anonfun$loadPlugins$5.85] com.testerhome.appcrawler.plugin.ReportPlugin@439b15f2
2017-10-25 19:08:51 INFO [Crawler.$anonfun$loadPlugins$5.85] com.testerhome.appcrawler.plugin.FreeMind@74fab04a
2017-10-25 19:08:51 INFO [TagLimitPlugin.init.17] com.testerhome.appcrawler.plugin.TagLimitPlugin init
2017-10-25 19:08:51 INFO [ReportPlugin.init.17] com.testerhome.appcrawler.plugin.ReportPlugin init
2017-10-25 19:08:51 INFO [FreeMind.init.17] com.testerhome.appcrawler.plugin.FreeMind init
2017-10-25 19:08:51 INFO [ReportPlugin.start.21] reportPath=/Users/autohome/Downloads/iOS_20171025190848
2017-10-25 19:08:51 INFO [ReportPlugin.start.24] create /Users/autohome/Downloads/iOS_20171025190848/tmp/ directory
2017-10-25 19:08:51 INFO [Crawler.start.126] prepare setup Appium
2017-10-25 19:08:51 INFO [Crawler.setupAppium.255] use AppiumClient
Exception in thread "main" org.openqa.selenium.WebDriverException: Unable to parse remote response: Parameters were incorrect. We wanted {"required":["desiredCapabilities"],"optional":["requiredCapabilities","sessionId","id","sessionId","id","sessionId","id","sessionId","id"]} and you sent ["desiredCapabilities","requiredCapabilities","capabilities"]
Build info: version: 'unknown', revision: 'unknown', time: 'unknown'
System info: host: 'localhost', ip: '127.0.0.1', os.name: 'Mac OS X', os.arch: 'x86_64', os.version: '10.11.6', java.version: '1.8.0_131'
Driver info: driver.version: IOSDriver
at org.openqa.selenium.remote.ProtocolHandshake.createSession(ProtocolHandshake.java:347)
at org.openqa.selenium.remote.ProtocolHandshake.createSession(ProtocolHandshake.java:136)
at org.openqa.selenium.remote.HttpCommandExecutor.execute(HttpCommandExecutor.java:142)
at io.appium.java_client.remote.AppiumCommandExecutor.execute(AppiumCommandExecutor.java:89)
at org.openqa.selenium.remote.RemoteWebDriver.execute(RemoteWebDriver.java:586)
at io.appium.java_client.DefaultGenericMobileDriver.execute(DefaultGenericMobileDriver.java:42)
at io.appium.java_client.AppiumDriver.execute(AppiumDriver.java:1)
at io.appium.java_client.ios.IOSDriver.execute(IOSDriver.java:1)
at org.openqa.selenium.remote.RemoteWebDriver.startSession(RemoteWebDriver.java:217)
at org.openqa.selenium.remote.RemoteWebDriver.(RemoteWebDriver.java:140)
at io.appium.java_client.DefaultGenericMobileDriver.(DefaultGenericMobileDriver.java:38)
at io.appium.java_client.AppiumDriver.(AppiumDriver.java:83)
at io.appium.java_client.AppiumDriver.(AppiumDriver.java:93)
at io.appium.java_client.ios.IOSDriver.(IOSDriver.java:78)
at com.testerhome.appcrawler.driver.AppiumClient.appium(AppiumClient.scala:163)
at com.testerhome.appcrawler.driver.AppiumClient.(AppiumClient.scala:38)
at com.testerhome.appcrawler.Crawler.setupAppium(Crawler.scala:256)
at com.testerhome.appcrawler.Crawler.start(Crawler.scala:127)
at com.testerhome.appcrawler.AppCrawler$.startCrawl(AppCrawler.scala:342)
at com.testerhome.appcrawler.AppCrawler$.parseParams(AppCrawler.scala:310)
at com.testerhome.appcrawler.AppCrawler$.main(AppCrawler.scala:90)
at com.testerhome.appcrawler.AppCrawler.main(AppCrawler.scala)

log2:Appium 端:
[HTTP] --> POST /wd/hub/session {"desiredCapabilities":{"app":"/Users/autohome/Downloads/CarPrice_V_201710240959.ipa","appium":"http://127.0.0.1:4723/wd/hub,noReset:false,autoLaunch:true,platformVersion:9.3.5,bundleId:com.autohome.quote,autoWebview:false,platformName:iOS,deviceName:iPhone" 6","autoAcceptAlerts":"true"},"requiredCapabilities":{},"capabilities":{"desiredCapabilities":{"app":"/Users/autohome/Downloads/CarPrice_V_201710240959.ipa","appium":"http://127.0.0.1:4723/wd/hub,noReset:false,autoLaunch:true,platformVersion:9.3.5,bundleId:com.autohome.quote,autoWebview:false,platformName:iOS,deviceName:iPhone" 6","autoAcceptAlerts":"true"},"requiredCapabilities":{},"alwaysMatch":{"platformName":"iOS"},"firstMatch":[]}}
[debug] [MJSONWP] Calling AppiumDriver.createSession() with args: [{"app":"/Users/autohome/Downloads/CarPrice_V_201710240959.ipa","appium":"http://127.0.0.1:4723/wd/hub,noReset:false,autoLaunch:true,platformVersion:9.3.5,bundleId:com.autohome.quote,autoWebview:false,platformName:iOS,deviceName:iPhone" 6","autoAcceptAlerts":"true"},{},{"desiredCapabilities":{"app":"/Users/autohome/Downloads/CarPrice_V_201710240959.ipa","appium":"http://127.0.0.1:4723/wd/hub,noReset:false,autoLaunch:true,platformVersion:9.3.5,bundleId:com.autohome.quote,autoWebview:false,platformName:iOS,deviceName:iPhone" 6","autoAcceptAlerts":"true"},"requiredCapabilities":{},"alwaysMatch":{"platformName":"iOS"},"firstMatch":[]}]
[debug] [BaseDriver] Event 'newSessionRequested' logged at 1508933290982 (20:08:10 GMT+0800 (CST))
[Appium] Creating new IosDriver (v1.27.4) session
[Appium] Capabilities:
[Appium] app: '/Users/autohome/Downloads/CarPrice_V_201710240959.ipa'
[Appium] appium: 'http://127.0.0.1:4723/wd/hub'
[Appium] noReset: 'false'
[Appium] autoLaunch: 'true'
[Appium] platformVersion: '9.3.5'
[Appium] bundleId: 'com.autohome.quote'
[Appium] autoWebview: 'false'
[Appium] platformName: 'iOS'
[Appium] deviceName: 'iPhone 6'
[Appium] autoAcceptAlerts: 'true'
[BaseDriver] Capability 'autoLaunch' changed from string to boolean. This may cause unexpected behavior
[BaseDriver] Capability 'autoWebview' changed from string to boolean. This may cause unexpected behavior
[BaseDriver] Capability 'noReset' changed from string to boolean. This may cause unexpected behavior
[BaseDriver] Capability 'autoAcceptAlerts' changed from string to boolean. This may cause unexpected behavior
[BaseDriver] The following capabilities were provided, but are not recognized by appium: appium.
[BaseDriver] Session created with session id: 20240eef-e017-49cb-8a8c-45e9de14a942
[debug] [iOS] Xcode version set to 7.3.1
[debug] [iOS] Not auto-detecting udid.
[BaseDriver] Using local app '/Users/autohome/Downloads/CarPrice_V_201710240959.ipa'
[debug] [BaseDriver] Copying local zip to tmp dir
[debug] [BaseDriver] Unzipping /var/folders/sk/5bgy7b2j38307vjh1t7zpzgm0000gn/T/2017925-2659-1qhojgt/appium-app.zip
[debug] [BaseDriver] Testing zip archive: /var/folders/sk/5bgy7b2j38307vjh1t7zpzgm0000gn/T/2017925-2659-1qhojgt/appium-app.zip
[BaseDriver] Unzipped local app to '/var/folders/sk/5bgy7b2j38307vjh1t7zpzgm0000gn/T/2017925-2659-1qhojgt/Payload/Autohome.app'
[debug] [iOS] Removing any remaining instruments sockets
[debug] [iOS] Cleaned up instruments socket /var/folders/sk/5bgy7b2j38307vjh1t7zpzgm0000gn/T/instruments_sock
[debug] [iOS] Setting iOS SDK Version
[debug] [iOS] iOS SDK Version set to 9.3
[debug] [Instruments] Getting list of devices instruments supports
[debug] [Instruments] Instruments is at: /Applications/Xcode 2.app/Contents/Developer/usr/bin/instruments
[debug] [Instruments] Available devices: iPhone6 (9.3.5) [c44fb3a903381a5272810fb2cdf9dbd7fed2b5e2],Apple TV 1080p (9.2) E6140A8C-AC6B-42DD-A31E-1CA98CE54B08,iPad 2 (9.1) B3A05CD2-F54D-4D11-8FE4-EE379E60A1EF,iPad 2 (9.3) DFB02337-277A-4A66-9E1A-B96BE6541E4E,iPad Air (9.1) F8DE6295-4671-4F60-A621-8BFC669B03EF,iPad Air (9.3) B69BD25C-757D-40D0-AB92-279A3395ED80,iPad Air 2 (9.1) AA770700-5AB6-4131-90E7-58939698DED6,iPad Air 2 (9.3) 5BFB8654-1ED1-4BC9-A5AA-5671F5ABCB93,iPad Pro (9.1) 74FE8335-7C01-4F66-95EC-BA1678AB27A0,iPad Pro (9.3) 0728F67B-8EDB-423F-BFE8-F2ED4FB2F82D,iPad Retina (9.1) 2DE0F479-AFE3-4857-999A-6E2773BCB194,iPad Retina (9.3) 4B3C7C09-6118-4604-9E37-DBD4E2227B91,iPhone 4s (9.1) A92C1C09-16DA-425A-98B1-1650B32C7C4C,iPhone 4s (9.3) F76C8AEC-426C-47B3-9B0A-72A674819D8D,iPhone 5 (9.1) AACB40FF-82A9-4539-BEE9-871AF77561B1,iPhone 5 (9.3) 8867E767-4932-4A5A-AF7E-FD8A564C3DAC,iPhone 5s (9.1) 68C80CE8-3004-49F1-9AAB-E8F035CE7346,iPhone 5s (9.3) 526B274E-B85C-4CEB-9D8A-EAC09340A418,iPhone 6 (9.1) 579EFAD3-2FA2-41E4-A4CA-F71FD96E441F,iPhone 6 (9.3) 5803935A-68C5-4183-AE1E-3D594A50FAB5,iPhone 6 Plus (9.1) F2F53824-FAFD-44A0-9C7E-952FD32E870C,iPhone 6 Plus (9.3) 32E20B86-0413-4376-B75F-B00F25D9E060,iPhone 6s (9.1) 209B437A-2A10-48A6-8F8A-CF51D453B738,iPhone 6s (9.3) D4D7DDDD-9F69-464D-91F6-BB39A49B6C8A,iPhone 6s (9.3) + Apple Watch - 38mm (2.2) 71185984-83F0-4D21-BFE5-E825D723B98E,iPhone 6s Plus (9.1) B22EEC59-002B-4BC2-9F2E-1F35EBE47BFA,iPhone 6s Plus (9.3) 3EAABD92-3FB0-41D9-B635-5D49FEE8E3CB,iPhone 6s Plus (9.3) + Apple Watch - 42mm (2.2) 3CE4DD1A-4595-4137-A5F2-1983251B9B5E
[debug] [iOS] Checking whether our device string is supported
[iOSSim] Retrieving device name string for Xcode version 7.3.1
[debug] [iOSSim] Getting device string from options: {"deviceName":"iPhone 6","platformVersion":"9.3.5","forceIphone":false,"forceIpad":false}
[debug] [iOSSim] Final device string is 'iPhone 6 (9.3.5)'
[iOS] Error: Could not find a device to launch. You requested 'iPhone 6 (9.3.5)', but the available devices were: ["iPhone6 (9.3.5) [c44fb3a903381a5272810fb2cdf9dbd7fed2b5e2]","Apple TV 1080p (9.2) E6140A8C-AC6B-42DD-A31E-1CA98CE54B08","iPad 2 (9.1) B3A05CD2-F54D-4D11-8FE4-EE379E60A1EF","iPad 2 (9.3) DFB02337-277A-4A66-9E1A-B96BE6541E4E","iPad Air (9.1) F8DE6295-4671-4F60-A621-8BFC669B03EF","iPad Air (9.3) B69BD25C-757D-40D0-AB92-279A3395ED80","iPad Air 2 (9.1) AA770700-5AB6-4131-90E7-58939698DED6","iPad Air 2 (9.3) 5BFB8654-1ED1-4BC9-A5AA-5671F5ABCB93","iPad Pro (9.1) 74FE8335-7C01-4F66-95EC-BA1678AB27A0","iPad Pro (9.3) 0728F67B-8EDB-423F-BFE8-F2ED4FB2F82D","iPad Retina (9.1) 2DE0F479-AFE3-4857-999A-6E2773BCB194","iPad Retina (9.3) 4B3C7C09-6118-4604-9E37-DBD4E2227B91","iPhone 4s (9.1) A92C1C09-16DA-425A-98B1-1650B32C7C4C","iPhone 4s (9.3) F76C8AEC-426C-47B3-9B0A-72A674819D8D","iPhone 5 (9.1) AACB40FF-82A9-4539-BEE9-871AF77561B1","iPhone 5 (9.3) 8867E767-4932-4A5A-AF7E-FD8A564C3DAC","iPhone 5s (9.1) 68C80CE8-3004-49F1-9AAB-E8F035CE7346","iPhone 5s (9.3) 526B274E-B85C-4CEB-9D8A-EAC09340A418","iPhone 6 (9.1) 579EFAD3-2FA2-41E4-A4CA-F71FD96E441F","iPhone 6 (9.3) 5803935A-68C5-4183-AE1E-3D594A50FAB5","iPhone 6 Plus (9.1) F2F53824-FAFD-44A0-9C7E-952FD32E870C","iPhone 6 Plus (9.3) 32E20B86-0413-4376-B75F-B00F25D9E060","iPhone 6s (9.1) 209B437A-2A10-48A6-8F8A-CF51D453B738","iPhone 6s (9.3) D4D7DDDD-9F69-464D-91F6-BB39A49B6C8A","iPhone 6s (9.3) + Apple Watch - 38mm (2.2) 71185984-83F0-4D21-BFE5-E825D723B98E","iPhone 6s Plus (9.1) B22EEC59-002B-4BC2-9F2E-1F35EBE47BFA","iPhone 6s Plus (9.3) 3EAABD92-3FB0-41D9-B635-5D49FEE8E3CB","iPhone 6s Plus (9.3) + Apple Watch - 42mm (2.2) 3CE4DD1A-4595-4137-A5F2-1983251B9B5E"]
at Object.wrappedLogger.errorAndThrow (../../lib/logging.js:66:13)
at noDevicesError (../../lib/device.js:21:12)
at checkSimulatorAvailable$ (../../lib/device.js:26:7)
at tryCatch (/usr/local/lib/node_modules/appium/node_modules/_babel-runtime@5.8.24@babel-runtime/regenerator/runtime.js:67:40)
at GeneratorFunctionPrototype.invoke as _invoke
at GeneratorFunctionPrototype.prototype.(anonymous function) as next
at GeneratorFunctionPrototype.invoke (/usr/local/lib/node_modules/appium/node_modules/_babel-runtime@5.8.24@babel-runtime/regenerator/runtime.js:136:37)
at run (/usr/local/lib/node_modules/appium/node_modules/_core-js@1.2.7@core-js/library/modules/es6.promise.js:108:47)
at /usr/local/lib/node_modules/appium/node_modules/_core-js@1.2.7@core-js/library/modules/es6.promise.js:119:28
at flush (/usr/local/lib/node_modules/appium/node_modules/_core-js@1.2.7@core-js/library/modules/$.microtask.js:19:5)
at _combinedTickCallback (node.js:370:9)
at process._tickCallback (node.js:401:11)
[Error: Could not find a device to launch. You requested 'iPhone 6 (9.3.5)', but the available devices were: ["iPhone6 (9.3.5) [c44fb3a903381a5272810fb2cdf9dbd7fed2b5e2]","Apple TV 1080p (9.2) E6140A8C-AC6B-42DD-A31E-1CA98CE54B08","iPad 2 (9.1) B3A05CD2-F54D-4D11-8FE4-EE379E60A1EF","iPad 2 (9.3) DFB02337-277A-4A66-9E1A-B96BE6541E4E","iPad Air (9.1) F8DE6295-4671-4F60-A621-8BFC669B03EF","iPad Air (9.3) B69BD25C-757D-40D0-AB92-279A3395ED80","iPad Air 2 (9.1) AA770700-5AB6-4131-90E7-58939698DED6","iPad Air 2 (9.3) 5BFB8654-1ED1-4BC9-A5AA-5671F5ABCB93","iPad Pro (9.1) 74FE8335-7C01-4F66-95EC-BA1678AB27A0","iPad Pro (9.3) 0728F67B-8EDB-423F-BFE8-F2ED4FB2F82D","iPad Retina (9.1) 2DE0F479-AFE3-4857-999A-6E2773BCB194","iPad Retina (9.3) 4B3C7C09-6118-4604-9E37-DBD4E2227B91","iPhone 4s (9.1) A92C1C09-16DA-425A-98B1-1650B32C7C4C","iPhone 4s (9.3) F76C8AEC-426C-47B3-9B0A-72A674819D8D","iPhone 5 (9.1) AACB40FF-82A9-4539-BEE9-871AF77561B1","iPhone 5 (9.3) 8867E767-4932-4A5A-AF7E-FD8A564C3DAC","iPhone 5s (9.1) 68C80CE8-3004-49F1-9AAB-E8F035CE7346","iPhone 5s (9.3) 526B274E-B85C-4CEB-9D8A-EAC09340A418","iPhone 6 (9.1) 579EFAD3-2FA2-41E4-A4CA-F71FD96E441F","iPhone 6 (9.3) 5803935A-68C5-4183-AE1E-3D594A50FAB5","iPhone 6 Plus (9.1) F2F53824-FAFD-44A0-9C7E-952FD32E870C","iPhone 6 Plus (9.3) 32E20B86-0413-4376-B75F-B00F25D9E060","iPhone 6s (9.1) 209B437A-2A10-48A6-8F8A-CF51D453B738","iPhone 6s (9.3) D4D7DDDD-9F69-464D-91F6-BB39A49B6C8A","iPhone 6s (9.3) + Apple Watch - 38mm (2.2) 71185984-83F0-4D21-BFE5-E825D723B98E","iPhone 6s Plus (9.1) B22EEC59-002B-4BC2-9F2E-1F35EBE47BFA","iPhone 6s Plus (9.3) 3EAABD92-3FB0-41D9-B635-5D49FEE8E3CB","iPhone 6s Plus (9.3) + Apple Watch - 42mm (2.2) 3CE4DD1A-4595-4137-A5F2-1983251B9B5E"]]
[MJSONWP] Encountered internal error running command: Error: Could not find a device to launch. You requested 'iPhone 6 (9.3.5)', but the available devices were: ["iPhone6 (9.3.5) [c44fb3a903381a5272810fb2cdf9dbd7fed2b5e2]","Apple TV 1080p (9.2) E6140A8C-AC6B-42DD-A31E-1CA98CE54B08","iPad 2 (9.1) B3A05CD2-F54D-4D11-8FE4-EE379E60A1EF","iPad 2 (9.3) DFB02337-277A-4A66-9E1A-B96BE6541E4E","iPad Air (9.1) F8DE6295-4671-4F60-A621-8BFC669B03EF","iPad Air (9.3) B69BD25C-757D-40D0-AB92-279A3395ED80","iPad Air 2 (9.1) AA770700-5AB6-4131-90E7-58939698DED6","iPad Air 2 (9.3) 5BFB8654-1ED1-4BC9-A5AA-5671F5ABCB93","iPad Pro (9.1) 74FE8335-7C01-4F66-95EC-BA1678AB27A0","iPad Pro (9.3) 0728F67B-8EDB-423F-BFE8-F2ED4FB2F82D","iPad Retina (9.1) 2DE0F479-AFE3-4857-999A-6E2773BCB194","iPad Retina (9.3) 4B3C7C09-6118-4604-9E37-DBD4E2227B91","iPhone 4s (9.1) A92C1C09-16DA-425A-98B1-1650B32C7C4C","iPhone 4s (9.3) F76C8AEC-426C-47B3-9B0A-72A674819D8D","iPhone 5 (9.1) AACB40FF-82A9-4539-BEE9-871AF77561B1","iPhone 5 (9.3) 8867E767-4932-4A5A-AF7E-FD8A564C3DAC","iPhone 5s (9.1) 68C80CE8-3004-49F1-9AAB-E8F035CE7346","iPhone 5s (9.3) 526B274E-B85C-4CEB-9D8A-EAC09340A418","iPhone 6 (9.1) 579EFAD3-2FA2-41E4-A4CA-F71FD96E441F","iPhone 6 (9.3) 5803935A-68C5-4183-AE1E-3D594A50FAB5","iPhone 6 Plus (9.1) F2F53824-FAFD-44A0-9C7E-952FD32E870C","iPhone 6 Plus (9.3) 32E20B86-0413-4376-B75F-B00F25D9E060","iPhone 6s (9.1) 209B437A-2A10-48A6-8F8A-CF51D453B738","iPhone 6s (9.3) D4D7DDDD-9F69-464D-91F6-BB39A49B6C8A","iPhone 6s (9.3) + Apple Watch - 38mm (2.2) 71185984-83F0-4D21-BFE5-E825D723B98E","iPhone 6s Plus (9.1) B22EEC59-002B-4BC2-9F2E-1F35EBE47BFA","iPhone 6s Plus (9.3) 3EAABD92-3FB0-41D9-B635-5D49FEE8E3CB","iPhone 6s Plus (9.3) + Apple Watch - 42mm (2.2) 3CE4DD1A-4595-4137-A5F2-1983251B9B5E"]
at Object.wrappedLogger.errorAndThrow (../../lib/logging.js:66:13)
at noDevicesError (../../lib/device.js:21:12)
at checkSimulatorAvailable$ (../../lib/device.js:26:7)
at tryCatch (/usr/local/lib/node_modules/appium/node_modules/_babel-runtime@5.8.24@babel-runtime/regenerator/runtime.js:67:40)
at GeneratorFunctionPrototype.invoke as _invoke
at GeneratorFunctionPrototype.prototype.(anonymous function) as next
at GeneratorFunctionPrototype.invoke (/usr/local/lib/node_modules/appium/node_modules/_babel-runtime@5.8.24@babel-runtime/regenerator/runtime.js:136:37)
at run (/usr/local/lib/node_modules/appium/node_modules/_core-js@1.2.7@core-js/library/modules/es6.promise.js:108:47)
at /usr/local/lib/node_modules/appium/node_modules/_core-js@1.2.7@core-js/library/modules/es6.promise.js:119:28
at flush (/usr/local/lib/node_modules/appium/node_modules/_core-js@1.2.7@core-js/library/modules/$.microtask.js:19:5)
at _combinedTickCallback (node.js:370:9)
at process._tickCallback (node.js:401:11)
[HTTP] <— POST /wd/hub/session 500 5233 ms - 2293

共收到 4 条回复 时间 点赞

Could not find a device to launch. You requested 'iPhone 6 (9.3.5)' 这句日志已经很明确告诉你是什么问题了。

改成用 udid 试试吧。

看你本地的可支持虚拟机或者真机的列表。默认的9.3.5找不到设备

陈恒捷 回复

嗯,我用udid可以了~~多谢

陈恒捷 回复

恢复错了,删除了

需要 Sign In 后方可回复, 如果你还没有账号请点击这里 Sign Up