iOS 测试 安装 WebDriverAgent 时遇到的两个问题

momoko · 2016年11月11日 · 最后由 xdf 回复于 2016年11月12日 · 113 次阅读

环境:xcode8.1

问题一:git 上下载了 webDriverAgent 后,运行./Scripts/bootstrap.sh,产生如下报错:

问题二:在上一个问题没有解决的基础上,我直接用 xcode 运行 WebDriverAgent.xcodeproj 这个文件,产生如下报错:

请问这两个问题有的产生相互有联系吗?该如何解决这两个问题?感谢!

共收到 5 条回复 时间 点赞

认真看下 webdriveragent 的 github 下面的文档 。。。。写得比较详细了。。。要装 Carthage,再运行./Scripts/bootstrap.sh 安装依赖

#1 楼 @wang04170 Carthage 是安装成功的,然后运行./Scripts/bootstrap.sh 就报错了

#2 楼 @u1449648501 第二个问题其实就是因为缺少依赖造成的, 建议:1、确认源码是从 facebook 的 github 上拉下来的最新的。2、确认是不是墙的关系,有的依赖可能会需要到的资源 (因为我一直都是的所以不确定)。3、我看你 WebdriverAgent-master 的目录怎么放到了 usr/lib/node_modules 的路径下了,建议你放到权限正确的比如 developer 这类文件夹去用 。。。。再不行那就报警吧-。-

#3 楼 @wang04170 我最初目的是要安装 macaca 的 inspector,结果安装过程完全没有报错的情况下,就去起不来 inspector,后台查了一下是缺少 webdriveragent 这个文件,所有手动去 git 上拉取的。刚才我换了一台 iOS10 的手机,再运行 webdriveragent,成功了……但是 inspector 仍旧跑步起来,so……我继续 google 吧……

@u1449648501 去看 issue 吧,包括关闭的,这时候比 Google 好用

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册