iOS 测试 请问一下大家 ios17 的自动化都是怎么跑的???

TD · 2023年11月03日 · 最后由 TD 回复于 2023年11月06日 · 4859 次阅读

现在我们很多手机都要升到 17 系统了 新机型都是 17 以上的,但是 ios 自动化的 support 文件只有 16.4,ios17 的自动化咋跑呢,大家有什么解决方案吗?

共收到 8 条回复 时间 点赞

没必要在最新系统上跑自动化吧,我们在 16 上就行了

TD #3 · 2023年11月03日 Author

有时候需要跑的兼容性测试,然后大家手机升级了也降不了

TD 回复

插回到 macmini 上

TD #1 · 2023年11月03日 Author
哲豪 回复

感觉是有点不想让在 Windows 跑,mac 上新装 xcode15 都换成需要下载 ios17 的模拟器文件了。但是测试很多人都没有 mac 呢

TD 回复

没办法,不行装个黑苹果虚拟机吧

TD 回复

要对设备管理有对应的策略啊,多少台应该升级,多少台保持在旧版本,不能说一股脑都升到最新版本,旧版本就不理了.
像 iOS 一般来说保持最近两三个版本就差不多了,大部分客户都会升级到最新版.

iOS 自动化与 Xcode 版本,Mac 电脑的系统版本,手机型号和 IOS 版本都有关系,一旦找到一个稳定的组合不要轻易升级任何版本,否则就会出现跑不起来的情况,尤其是 IOS 版本,应为手机系统升上去就降不回去,基本就完犊子了,本人就在这地方踩过坑,对于 IOS 自动化测试来说非必要不用升级。

TD #8 · 2023年11月06日 Author

我也踩过这个坑的。。。但是我是面对测试很多手机,不是我自己的手机,之前他们手机系统升级了我要帮他们适配 WDA 就得跟着升级 xcode,xcode 升级不了就升级 mac,也是一步步踩过的,现在看到龙测他们之前提过 ios 自动化不依赖 WDA,其他人有试验过吗?

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册