问答 启动 STF,执行 ./stf local --public-ip (本机公网 IP) --allow-remote 报错

天天测测晕晕乎乎 · August 30, 2019 · Last by wjTest replied at April 20, 2021 · 7685 hits

1、
执行 ./stf doctor 检查 stf 环境正常

2、
启动 STF ./stf local --public-ip (本机公网 IP) --allow-remote 却报错

请问这是什么情况?

共收到 8 条回复 时间 点赞

不加 allow remote,其他机器应该也能访问吧。我之前装的时候,查资料说是 node 必须用 node8,你的是 node9,不晓得是不是有影响。在 linux 装直接用 docker 镜像应该会方便很多吧

对 fengzx120 回复

不加 allow remote,也同样启动不了,报同样的错误

Unable to connect to 127.0.0.1:28015
rethinkdb 有问题

对 arrow 回复

OK,已使用 docker 成功搭建环境,感谢解答!

我的是利用官方的 dockerfile 去构建的镜像,启动报了和你遇到的错误一样,请问怎么处理的呢,搞的焦头烂额了

对 丽丽 回复

我是 直接使用 docker 提供的镜像

请问具体是怎么解决的? 我也碰到这个问题了


我也遇到了,查了半天说是 rethinkdb 没启动。手动启动 rethinkdb 后结束不了,我把终端放在那边不关,重开一个终端,再启动 stf 就正常了

需要 Sign In 后方可回复, 如果你还没有账号请点击这里 Sign Up。