Selenium AutoLine 开源平台部署安装教程

smallnine · 2018年05月15日 · 最后由 smallnine 回复于 2018年05月23日 · 751 次阅读

AutoLine项目地址:https://github.com/small99/AutoLine

安装手册

MySQL安装及配置

下载最新版的Mysql安装,具体安装方法,请自行参照相关文档。

  1. 使用utf-8编码创建一个名为autoline的数据库

  2. 修改.env配置文件中的数据库连接字符串,如下:

DATABASE_URL=mysql+pymysql://root:123456@127.0.0.1/autoline

TRIGGER_DATABASE_URL=mysql+pymysql://root:123456@127.0.0.1/autoline

注:

  1. root:123456 改为你的MySQL账号和密码

  2. 127.0.0.1 改为你的MySQL服务器的IP地址

AutoLine依赖包安装

如何安装AutoLine相关依赖包?

  1. 直接在 https://github.com/small99/AutoLine 下载

  2. 或通过git命令clone:

git clone https://github.com/small99/AutoLine

等待下载完成, 在AutoLine根目录下的requirements.txt即为相关依赖包文件,使用下面的命令安装依赖

  1. 需要先安装好Python3,最好将pip升级到最新的版本(python),先升级pip

python -m pip install --upgrade pip

  1. 安装AutoLine依赖包:

pip install -r requirements.txt

初始化数据库

首次启动时,需要初始化数据库建表和数据信息:

使用下面命令初始化建表

  1. 初始化

    python manage.py db init

  2. migrate

    python manage.py db migrate

  3. upgrade

    python manage.py db upgrade

如果你修改了数据库模型,即修改了models.py中的表字段,运行上述的2和3即可修改表结构

初始化数据

第一次运行时,需要初始化数据,使用下面的命令即可:

python manage.py deploy

运行

运行方式分为两种

  1. 默认方式,只能在本机访问

    python manage.py runserver
    此时只能通过http://127.0.0.1:5000来访问

  2. 外网访问模式

    python manage.py runserver -h 0.0.0.0 -p 8080

-h 用于绑定本机IP

-p 用于指定端口

这是你可以通过http://ip:端口 来访问平台了,只要能ping到你IP地址的机器均可访问平台

可能碰到的问题

  1. 提示pip不是最新版,请根据上面的提示先更新你的pip版本

  2. 提示缺依赖包,请根据提示信息,手动pip install xxx 来安装缺的依赖包

  3. 发现任何问题,请优先重新到github拉取最新的代码

看两张AutoLine的图,了解下AutoLine

最佳回复

seleniumlibrary等测试库没有加载出来,望大神指点一二

共收到 18 条回复 时间 点赞

棒棒的

seleniumlibrary等测试库没有加载出来,望大神指点一二

amber_cheng 回复

看下你doc下目录是否存下对应测试库的xml文件

amber_cheng 回复

你到github上找到公众号二维码,关注下 获取微信群 加入方式吧 到微信群里交流。这里就不留这些信息,免得广告嫌疑😂 😂 😂

smallnine 回复

1.doc目录下有了对应的测试库的xml文件
2.D:\python3.6\Lib\site-packages目录下已经安装了SelenumLibrary等测试库
3.本地安装的是python3.6,是不是因为版本太高,不兼容引起的?

amber_cheng 回复

不是,因为doc下有User Guide目录,未过滤掉导致加载关键字xml失败,你重新拉去下代码,已经修复这个问题了

前排采坑队伍报到,求个快速使用demo。。。

BensonMax 回复

AutoLine开源平台简明使用教程,晚上会写好,明天一早发布到公众号,谢谢

第一次配置数据库配错了,怎么重新初始化数据库?

yuyuyuyushui 回复

更新下最新的代码,删除根目录下的migrations这个目录,再按初始化的步骤来做就OK了

init database 报错了,请问是什么原因

➜ ~ python /Users/cgx/AutoLine-master/manage.py db init

Traceback (most recent call last):
File "/Users/cgx/AutoLine-master/manage.py", line 15, in
from app import create_app, db
File "/Users/cgx/AutoLine-master/app/init.py", line 20, in
from config import config
File "/Users/cgx/AutoLine-master/config.py", line 66, in
class ProductionConfig(Config):
File "/Users/cgx/AutoLine-master/config.py", line 68, in ProductionConfig
SQLALCHEMY_DATABASE_URI = os.environ.get('DATABASE_URL') + "?charset=utf8" or 'sqlite:///' + os.path.join(basedir, 'AutoLine.sqlite')
TypeError: unsupported operand type(s) for +: 'NoneType' and 'str'
➜ ~

sosocgx 回复

你需要更新下最新的代码

  1. 确保你的是python3
  2. mysql使用utf-8创建数据库
  3. init前 先删除AutoLine目录下存在的migrations目录
sosocgx 回复

请先cd 到 AutoLine目录下在运行相应的命令

感谢您的恢复和分享,已经可以在本地跑起来了。
另外说明文档里面有一处拼写错误:manage

migrate

python manange.py db migrate

sosocgx 回复

已经修订错误的命令

楼主,我运行项目后,一致报以下的错误

这是啥原因啊,有遇到过吗??

yiran0921 回复

你的代码需要更新下,这个问题已经修复

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册