Appium #appium-desktop#appiumdesktop 中建立新的 session 后,start 时 提示 An unknown server-side error occurred while processing the command. Original error: Invalid Version: android-4.4,应该怎么配置 sdk 呢

lucky6 · 2018年04月09日 · 最后由 abee 回复于 2018年04月18日 · 726 次阅读

使用 appium 建立新的 session,各参数没有问题,点击 start 后提示 An unknown server-side error occurred while processing the command. Original error: Invalid Version: android-4.4
是 sdk 配置的有问题么,应该怎么配置,求各位大神直接,谢谢!!

共收到 7 条回复 时间 点赞

看这个错误应该是你模拟器或真机系统版本是 4.4,而 platformVersion 中写的是 6.0.1,platformVersion 修改为和模拟器或真机版本一致试试

田超 回复

用的真机,真机版本是 6.0.1

lucky6 回复

真机版本一定要是 Android 的系统版本,不能是系统 UI 的版本,如果你的 6.0.1 确实是 Android 系统版本,那只能说我也不清楚了

我也遇到这个问题了,同求解决思路!
另外,我在 Github 上看到,有人说是因为 ANDROID_HOME/build-tools 文件夹下有 “android-4.4w” 的文件夹,我改了名后仍然报同样的错。

我也遇到了同样的问题,目前还在找原因……

这个问题我解决了。我的方法是在 eclipse 里安装 adt 插件,中途遇到了一个 “adb server version (32) doesn't match this client (39)” 错误,发现可能是 360 手机助手的原因,有 360 或 HTC Sync 这样会启用不同版本 adb server 导致和 Appium 的 adb server 起冲突的情况,最好停止前者的服务或者卸载,然后就可以跑了。

你去 sdk manager.exe 里面看看你的 sdk 版本是不是低于当前系统的版本,我升级完成后,这个问题解决了。

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册