Appium [已解决] 在 ios 上用 appium 查看页面元素,发现有的元素的 name 属性为 AX error -25205,这是撒?

xiaohengdada for 转转QA · 2017年10月09日 · 最后由 xiaoxiao55 回复于 2018年01月06日 · 1368 次阅读

共收到 23 条回复 时间 点赞
Lihuazhang 回复

3Q,我看里面主要集中三点,一是代理,二是appium进程太多,三是重启。我已经把代理去掉了,appium进程也都杀了。还是不行。只能重启试试了。用的XCODE9

我也出现了,怎么办

lily241 回复

你是因为什么原因出现的呀?也是升级xcode后出现的?

5楼 已删除
xiaohengdada 回复

升级到xcode9出现的💧

lily241 回复

和我一模一样

xiaohengdada 回复

早知道不更新了,有坑啊

lily241 回复

不更新不行啊,开发那边都更新到xcode9了,做持续集成的话要跟着更新

lily241 回复

你扣扣号多少?价格好友私聊下

xiaohengdada 回复

你解决了?

lily241 回复

没,所以私聊下看看怎么解决,扣扣1013005772

这个问题我也遇到了,请问解决了吗?

weamylady 回复

暂时没找到方法

weamylady 回复

解决了,你也是升级xcode9造成的?

xiaohengdada 回复

是的,有啥解决办法没?

xiaohengdada 回复

请问是怎么解决的?我也遇到了

wda上了该问题的解法了:https://github.com/facebook/WebDriverAgent/issues/703

xcode9 目前看必须用ios11的设备跑,就没有问题

dengwei729 回复

对的,IOS系统至少11

升级Xcode9之后,inspector所有元素的name、value属性都是AX error -25205,有没有已经解决的童鞋。

cailele213 回复

要连ios11的设备

lily241 回复

同升级xcode9出现

23楼 已删除
xiaohengdada 回复

手机系统和appium桌面版最新的话,就没有该问题

同求问,appium桌面版不支持iOS11系统之前的了?我也遇到了~

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册