问答 Mac 版本 10.12.5 终端安装 appium,输入 gem install xcpretty 遇到一个问题 While executing gem ... (Gem::DependencyError) Unable to resolve dependencies: xcpretty requires rouge (~> 2.0.7)

浅浅 · 2017年07月20日 · 最后由 edsion 回复于 2017年08月15日 · 121 次阅读

Mac 版本 10.12.5 终端安装 appium,输入 gem install xcpretty 遇到一个问题 While executing gem ... (Gem::DependencyError) Unable to resolve dependencies: xcpretty requires rouge (~> 2.0.7)

共收到 12 条回复 时间 点赞

终端输入。sudo gem install xcpretty

@17701331064
很无奈,卡到这了

使用命令: gem -v 查看版本。
查看版本是否符合,如果不符合,请升级版本

@chaos 非常感谢,解决燃眉之急

@chaos
具体怎么操作 还请指点,不知道怎么下载

浅浅 回复

@GESHUOYAN 你是否安装Xcode切成功打开过?

@chaos 是的 我先安装的 xcode ,再手动安装的 appium 卡到这个问题了

@chaos 打开 xcode 可以运行项目,xcode 没问题,不过我用的是 xcode8.2

浅浅 回复

@GESHUOYAN brew install carthage 安装了吗?

浅浅 #10 · 2017年07月25日 Author

@chaos 安装了

匿名 #2 · 2017年08月15日

这个东西可装可不装的 xcpretty 主要用于对 xcodebuild 的输出进行格式化。并包含输出 report 功能
或者升级也行 gem update

gem update --system

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册