UiAutomator Uiautomator1.0 的 jar 包可以在 android6.0 上运行成功,在 android7.0 上运行报错,有大神知道解决方案吗

qvb1213 · 发布于 2017年01月12日 · 最后由 flybug 回复于 2017年03月23日 · 1514 次阅读

Uiautomator1.0的jar包可以在android6.0上运行成功,在android7.0上运行报错,有大神知道解决方案吗

共收到 11 条回复
13536

Android7.0要用uiautomator2

13536

我在android7.1和android7.0模拟器上跑appium脚本可以 可惜没android7真机

96
qvb1213 · #3 · 2017年01月13日 作者

暂时还不会uiautomator2。。。。。 有什么教程推荐啊
#1楼 @wxlsh114

13536

木有 我写的python脚本

13728

@wxlsh114 UiAutomator1.0 不支持Android 7.0,这个有文档说明吗,你是在哪看到的?

13536

#5楼 @TesterWang 运行脚本时 appium 或macaca有提示信息的让用uiautomator2

13728

@wxlsh114 ,Appium1.6.0以下封装的是UiAutomator1.0,1.6.0以上封装的是UiAutomator2.0,macaca暂时还没有用过,我用UiAutomator1.0写的脚本可以在Android7.0真机上跑起来的,UiAutomator2.0和Robotium都可以跑起来。

13536

#8楼 @TesterWang 我用的是appium 1.6.3

96
qvb1213 · #10 · 2017年01月16日 作者

今天发现更新sdk后重新打包可以测试,多谢楼上各位大神🙏

96

appium中只有android 6.0的,怎么在android 7.0的真机上跑,升级appium可以解决还有可以通过插件方式解决吗?

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册