问答 UI 自动化基于 playwright 开发的框架,playwright 的 1.33.0 版本是可以正常运行。但是 playwright 版本升级后(最新版 1.43.0),框架无法运行

lam · 2024年05月17日 · 最后由 紫藤Ivy 回复于 2024年05月20日 · 2999 次阅读

UI 自动化基于 playwright 开发的框架,playwright 的 1.33.0 版本是可以正常运行。但是 playwright 版本升级后(最新版 1.43.0),框架无法运行。
在不做任何改动,只升级 playwright 版本后,运行时提示的大概意思是我使用同步的写法中使用了异步的接口

共收到 3 条回复 时间 点赞

pip 升级 playwright 后,没有执行 playwright install 升级浏览器吧?这样可能会导致你描述的问题。

看不懂,你应该改善下你提问问题的方式

把你的报错贴到 AI 软件里面。AI 对解决 ENV 问题还是效率很高的~

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册