STF Setup had an error Error: At least one of these paths should exist

jack · 2020年05月07日 · 最后由 pablo 回复于 2021年03月18日 · 247 次阅读

启动 stf 服务后,连上手机,后台一直报错,手机型号是华为 V30,安卓版本是 10.
2020-05-07T11:09:51.604Z FTL/device 6082 [PKT0219B28002280] Setup had an error Error: At least one of these paths should exist: /usr/local/node/node-v9.10.0-linux-x64/lib/node_modules/stf/node_modules/minicap-prebuilt/prebuilt/arm64-v8a/lib/android-29/minicap.so, /usr/local/node/node-v9.10.0-linux-x64/lib/node_modules/stf/node_modules/minicap-prebuilt/prebuilt/arm64-v8a/lib/android-29/minicap.so, /usr/local/node/node-v9.10.0-linux-x64/lib/node_modules/stf/node_modules/minicap-prebuilt/prebuilt/armeabi-v7a/lib/android-29/minicap.so, /usr/local/node/node-v9.10.0-linux-x64/lib/node_modules/stf/node_modules/minicap-prebuilt/prebuilt/armeabi-v7a/lib/android-29/minicap.so, /usr/local/node/node-v9.10.0-linux-x64/lib/node_modules/stf/node_modules/minicap-prebuilt/prebuilt/armeabi/lib/android-29/minicap.so, /usr/local/node/node-v9.10.0-linux-x64/lib/node_modules/stf/node_modules/minicap-prebuilt/prebuilt/armeabi/lib/android-29/minicap.so
at Object.module.exports.requiredMatch (/usr/local/node/node-v9.10.0-linux-x64/lib/node_modules/stf/lib/util/pathutil.js:33:9)

共收到 3 条回复 时间 点赞

不知道大佬最后又找到解决方案嘛?

你连的手机是 Android10 吧?
我看网上好像说 minitouch 不支持 Android10 了
https://www.jianshu.com/p/40eacd3a736e

我也遇到同样问题,你是怎么解决的呢

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册