STF STF 平台连接华为手机报错,请问有没有大佬遇见过,求解

lizhouquan · 2020年04月01日 · 最后由 pablo 回复于 2021年03月18日 · 162 次阅读

FTL/device 33660 [66J5T18A28017605] Setup had an error Error: At least one of these paths should exist: /usr/local/lib/node_modules/stf/node_modules/minicap-prebuilt/prebuilt/arm64-v8a/lib/android-29/minicap.so, /usr/local/lib/node_modules/stf/node_modules/minicap-prebuilt/prebuilt/arm64-v8a/lib/android-29/minicap.so, /usr/local/lib/node_modules/stf/node_modules/minicap-prebuilt/prebuilt/armeabi-v7a/lib/android-29/minicap.so, /usr/local/lib/node_modules/stf/node_modules/minicap-prebuilt/prebuilt/armeabi-v7a/lib/android-29/minicap.so, /usr/local/lib/node_modules/stf/node_modules/minicap-prebuilt/prebuilt/armeabi/lib/android-29/minicap.so, /usr/local/lib/node_modules/stf/node_modules/minicap-prebuilt/prebuilt/armeabi/lib/android-29/minicap.so
at Object.module.exports.requiredMatch (/usr/local/lib/node_modules/stf/lib/util/pathutil.js:33:9)
at /usr/local/lib/node_modules/stf/lib/units/device/resources/minicap.js:41:23
at SerialSyrup.ParallelSyrup.invoke (/usr/local/lib/node_modules/stf/node_modules/_stf-syrup@1.0.0@stf-syrup/lib/parallel.js:54:24)
at /usr/local/lib/node_modules/stf/node_modules/_stf-syrup@1.0.0@stf-syrup/lib/serial.js:43:33
at tryCatch1 (/usr/local/lib/node_modules/stf/node_modules/_bluebird@1.1.1@bluebird/js/main/util.js:63:19)
at Promise$_callHandler as _callHandler
at Promise$_settlePromiseFromHandler as _settlePromiseFromHandler
at Promise$_settlePromiseAt as _settlePromiseAt
at Promise$_fulfillPromises as _fulfillPromises
at Async$_consumeFunctionBuffer as _consumeFunctionBuffer
at Async$consumeFunctionBuffer (/usr/local/lib/node_modules/stf/node_modules/_bluebird@1.1.1@bluebird/js/main/async.js:37:14)
at _combinedTickCallback (internal/process/next_tick.js:132:7)
at process._tickCallback (internal/process/next_tick.js:181:9)

共收到 6 条回复 时间 点赞

更新一下 stf,你这个老的 stf 不支持 Android10 的手机吧

2楼 已删除

大佬,你这边是怎么 搭建 stf 的 我这边为什么搭建完 windows 访问 一直拒绝连接呢

大佬,你这个问题解决了吗

zyx 回复

@zyx 我使用的 mac

@senko 更到最新的 stf 就解决了

大佬,遇到同样问题了。。。我的 stf3.4.1 了,也不行么?怎么更新最新的啊

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册