问答 求助:MAC 系统下载安装 Jmeter ,启动后 log 文件中输出大量的报错信息

carrot_me · 2018年10月08日 · 最后由 carrot_me 回复于 2018年10月09日 · 414 次阅读

mac系统,第一次安装 Jmeter ,从官网下载 tgz 包解压,启动 Jmeter 后, terminal 中输出信息如下图:

并且 log 文件中输出大量报错信息,例如:

然后尝试创建、运行测试脚本,可以正常运行以及查看结果。

第一次遇到这种情况,也查阅了一些网站,并没有解决问题;
请问各位大神,出现这些报错是什么原因呢?如何解决这些报错呢?

最佳回复
carrot_me 回复

我试了下,没有报错信息,估计是你的环境哪里有问题。
你那个错误有可能是 lib 文件夹下面有包名为 java.* 的 jar包,因为JMeter是通过ClassLoader去加载lib下面的jar包,而java因为安全原因又不允许动态加载以java. 开头的包,所以会报错,但是并不影响使用。

共收到 6 条回复 时间 点赞

JDK版本是多少,JMeter版本是多少?

2楼 已删除
3楼 已删除
吴宝林 回复

JDK 的版本是 1.8 ,JMeter 版本是 5.0

用的是jmeter 4,一切正常。

carrot_me 回复

我试了下,没有报错信息,估计是你的环境哪里有问题。
你那个错误有可能是 lib 文件夹下面有包名为 java.* 的 jar包,因为JMeter是通过ClassLoader去加载lib下面的jar包,而java因为安全原因又不允许动态加载以java. 开头的包,所以会报错,但是并不影响使用。

我下载的是Jemeter4.0版本的,九月中旬下载的,运行时一切正常。
使用的时候更新了java版本(卸载原版本),
我mac上java查询结果:
java 10.0.2 2018-07-17
Java(TM) SE Runtime Environment 18.3 (build 10.0.2+13)
Java HotSpot(TM) 64-Bit Server VM 18.3 (build 10.0.2+13, mixed mode)
你对比下看是那里出问题了。

吴宝林 回复

根据你说的我去检查了所有引入的外部jar包,找到原因了,确实是多复制了一个包含java基础类库的jar包,删掉就没有问题了~谢谢你啦~

carrot_me 关闭了讨论 10月09日 18:50
carrot_me 重新开启了讨论 10月09日 18:51
carrot_me 关闭了讨论 10月09日 18:51
需要 登录 后方可回复, 如果你还没有账号请点击这里 注册