接口测试 pip 解决升级问题

阮可赞 · July 23, 2018 · Last by 瓶子 replied at August 15, 2018 · 2124 hits

python导入requests模块时需要pip安装,安装时提示
You are using pip version 9.0.1, however version 18.0 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

  1. 执行pip install --upgrade pip 仍然提示这个信息
  2. 上网查可能是sudo问题,执行sudo pip install --upgrade pip 仍然提示这个消息,内心有点儿不知所错了
  3. 继续搜,可以试试 python -m pip install --upgrade pip命令,为了保险起见,执行 sudo python -m pip install --upgrade pip 成功了,可以安装各个模块了,开心~
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
共收到 1 条回复 时间 点赞

windows系统下成功的么

需要 Sign In 后方可回复, 如果你还没有账号请点击这里 Sign Up